Search found 14 matches

by vineet
Mon Apr 15, 2019 8:25 am
Forum: Inetlab.SMPP v2.x (.NET Standard, .NET Core)
Topic: Tag Return Null in Submit Response
Replies: 1
Views: 48

Tag Return Null in Submit Response

Hi, we are setting the tag property like this ISubmitSmBuilder builder = SMS.ForSubmit() .Text(messageText) .From(sourceAddress) .To(destinationAddress) .Coding(coding) .Set(s => s.Tag = 23); batch.AddRange(builder.Create(SMPPClient)); but tag always return null in var resp = (await SMPPClient.Submi...
by vineet
Tue Sep 11, 2018 8:02 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Deliver_sm Submit Date and Done Date Missing Seconds Part
Replies: 1
Views: 577

Deliver_sm Submit Date and Done Date Missing Seconds Part

Hi, The deliver_sm is sending the following receipt id:d111f7b8-9643-4ecf-b1ca-ce4bf95fbb0d sub:000 dlvrd:000 submit date:1809111327 done date:1809111327 stat:REJECTD err:1003 text:This is a test I always send submit date and done date with datetime property but it always take removes the second par...
by vineet
Wed Jun 27, 2018 9:20 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Remove Additional Paramters
Replies: 2
Views: 754

Re: Remove Additional Paramters

Hi Alt,

please see the attached wireshark log.
infotech.zip
by vineet
Tue Jun 12, 2018 8:02 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Remove Additional Paramters
Replies: 2
Views: 754

Remove Additional Paramters

Hi, Library is sending extra parameters like extraParms=Validity=2D is there is any option to remove it from the request because operator is adding ++ and @@ sign in front and back of message 17:48:44:216 [15] SMPPServerReceiveMessageCallback: inbound message: sender=KENSMS, recip=+919811883282, pid...
by vineet
Wed Nov 22, 2017 6:09 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Get Systemid in smppserver logger
Replies: 6
Views: 1801

Re: Get Systemid in smppserver logger

Hi Where can i get the SystemId in the looger class mentioned below public class SMPPLogger : ILog { private readonly string _loggerName; public SMPPLogger(string loggerName) { _loggerName = loggerName; } public string Name { get { return _loggerName; } } public void Error(object message, Exception ...
by vineet
Wed Nov 22, 2017 6:07 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: ESME_RTHROTTLED When Setting ReceiveSpeedLimit
Replies: 2
Views: 988

Re: ESME_RTHROTTLED When Setting ReceiveSpeedLimit

Hi, You are most welcome and thank you for such a wonderful smpp library it really helped us in making our SMS switch a breeze. Please provide a download link for version 1.2.9 i downloaded from this link http://www.inetlab.com/Downloading/Inetlab.SMPP.zip but it contains version 1.2.8 Thanks Vineet
by vineet
Fri Nov 17, 2017 9:50 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Get Systemid in smppserver logger
Replies: 6
Views: 1801

Re: Get Systemid in smppserver logger

Hi, Still confused where to add this code. Please take a look at the existing code public SMPPServer() { InitializeComponent(); LogManager.SetLoggerFactory(loggerName => new SMPPLogger(loggerName)); //Need To Set The LoggerName For Each Connected Client? AppDomain.CurrentDomain.UnhandledException +=...
by vineet
Fri Nov 17, 2017 9:43 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: ESME_RTHROTTLED When Setting ReceiveSpeedLimit
Replies: 2
Views: 988

ESME_RTHROTTLED When Setting ReceiveSpeedLimit

Hi, Whenever we set the ReceiveSpeedLimit in SMPP Server we get ESME_RTHROTTLED for the first message after bind. after that all messages goes through without this error. This problem do not come if we do not set ReceiveSpeedLimit. Again it only happens for 1st message after successful connection/bi...
by vineet
Tue Sep 05, 2017 8:30 pm
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Get Systemid in smppserver logger
Replies: 6
Views: 1801

Get Systemid in smppserver logger

Hi is it possible to get systemid in smpp server global logger so the logs can be identified for each connected client.
by vineet
Thu Aug 17, 2017 8:56 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: SMPPCLIENT_NOCONN on evSubmitComplete
Replies: 1
Views: 1083

SMPPCLIENT_NOCONN on evSubmitComplete

Hi, We are getting SMPPCLIENT_NOCONN on evSubmitComplete for a particular provider. Before sending the message we check if client is bound or not then only we process the message for submission. In this case we always get ConnectionStatus.Bound == true so we send the message but on evSubmitComplete ...
by vineet
Tue May 16, 2017 4:59 pm
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Access Custom Parameter ID In client_evSubmitComplete
Replies: 4
Views: 1782

Re: Access Custom Parameter ID In client_evSubmitComplete

Thanks a lot for help. there is no issue if it receives same tag for each message part as in db design it is the main message id connected with message parts tables so it will be real easy to implement thanks a lot for the help.
by vineet
Tue May 16, 2017 4:34 pm
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Access Custom Parameter ID In client_evSubmitComplete
Replies: 4
Views: 1782

Re: Access Custom Parameter ID In client_evSubmitComplete

Please show a code snippet how to set a tag property i am unable to find it. here is the code DataCodings coding = GetDataCoding(); byte srcTon = byte.Parse(tbSrcAdrTON.Text); byte srcNpi = byte.Parse(tbSrcAdrNPI.Text); string srcAdr = tbSrcAdr.Text; byte dstTon = byte.Parse(tbDestAdrTON.Text); byte...
by vineet
Tue May 16, 2017 3:53 pm
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Access Custom Parameter ID In client_evSubmitComplete
Replies: 4
Views: 1782

Access Custom Parameter ID In client_evSubmitComplete

Hi,

I want to send message using SubmitAsync() function is there way i can fetch the custom id like 34455 in client_evSubmitComplete
so i can relate this id with the db and update the messageid in the db. if possible please provide a sample.
by vineet
Sat May 06, 2017 7:11 pm
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: client_evEnquireLink Event do not fire
Replies: 1
Views: 1362

client_evEnquireLink Event do not fire

Hi, i am using the full license version and downloded the latest library. Tried using demo application to connect to smpp server connection was sucessfully and in the log i can see enquire link send and pdu received but i put the breakpoint on client_evEnquireLink Event but it never get fired instea...