License detection issue.

.NET library for SMPP protocol
Post Reply
wcchor
Posts: 3
Joined: Mon Mar 20, 2017 8:21 am

License detection issue.

Post by wcchor » Fri Apr 28, 2017 2:36 am

I was facing a fairly critical error this morning where the library suddenly says my evaluation copy has expired and my program just stopped there.

Kindly refer to log below:

20.04.2017 18:56:16:INFO : 1: Inetlab.SMPP v.1.1.29.1. (3/15/2017) FULL VERSION. Licensed to 'XXXXXXXX'
----- Other contents ------
28.04.2017 07:00:11:ERROR:123: Event evDisconnected failed
Exception: System.ComponentModel.LicenseException: Inetlab.SMPP evaluation period has been expired.

As you can see, the license was just purchased a month ago, and the last time I restarted it was about a week ago.
Why would this morning out of sudden it tells me the evaluation period has expired? Program works fine right after I restarted it with log below:

28.04.2017 10:23:49:INFO : 1: Inetlab.SMPP v.1.1.29.1. (3/15/2017) FULL VERSION. Licensed to 'XXXXXXXX'

Could you please enlighten me what's the issue here? Does the license verification requires active internet connection?

alt
Site Admin
Posts: 726
Joined: Tue Apr 25, 2006 9:45 am

Re: License detection issue.

Post by alt » Wed May 03, 2017 2:34 pm

No, license verification doesn't require active internet connection.

Please write me a message. We shall try to solve this issue by email.

zemlvp
Posts: 3
Joined: Wed Nov 21, 2018 6:23 am

Re: License detection issue.

Post by zemlvp » Wed Nov 21, 2018 6:26 am

the same error

21.11.2018 09:15:40:INFO : 11: Inetlab.SMPP v.1.1.22.7. FULL VERSION. Licensed to '---'

21.11.2018 04:24:35:ERROR:445: Event evDisconnected failed
Exception: System.ComponentModel.LicenseException: Inetlab.SMPP evaluation period has been expired.
at T3Wec71fufoINgL8jiZ.fhS3Bj1HixKJkGbI5xM.RobriOMjHW(Object )
at Inetlab.SMPP.SmppClient.ConnectAsync(IPEndPoint endPoint)
at Inetlab.SMPP.SmppClient.ConnectAsync(String hostName, Int32 port)

zemlvp
Posts: 3
Joined: Wed Nov 21, 2018 6:23 am

Re: License detection issue.

Post by zemlvp » Wed Nov 21, 2018 7:37 am

In Change log I see that this bug was fixed in latest version
I downloaded latest version v.1.3.2.0. (06.08.2018), by my Inetlab.SMPP.license not valid

Added "Inetlab.SMPP.license" into the root of project, added to referense.
Changed "Build Action" of the file to "Embedded Resource".

LicenseManager.SetLicense(this.GetType().Assembly.GetManifestResourceStream(this.GetType(), "Inetlab.SMPP.license"))
return false
and show 10:30:51: INFO : 9: (SmppClient1) Inetlab.SMPP v.1.3.2.0. (06.08.2018) TRIAL VERSION.

alt
Site Admin
Posts: 726
Joined: Tue Apr 25, 2006 9:45 am

Re: License detection issue.

Post by alt » Wed Nov 21, 2018 7:43 am

This is known issue in third-party licensing module. It happens sometimes on some windows machines after midnight. It has something to do with date change in this module.
Inetlab.SMPP library has own licensing module since v1.3.

You should consider to upgrade to latest version. Send me your purchase number to support@ and I give you instructions how to do it.

alt
Site Admin
Posts: 726
Joined: Tue Apr 25, 2006 9:45 am

Re: License detection issue.

Post by alt » Wed Nov 21, 2018 7:45 am

The file "Inetlab.SMPP.license" for new licensing module has another format.

zemlvp
Posts: 3
Joined: Wed Nov 21, 2018 6:23 am

Re: License detection issue.

Post by zemlvp » Wed Nov 21, 2018 7:55 am

Can we get "Inetlab.SMPP.license" for new licensing module ?

Post Reply