Search found 6 matches

by striemer
Fri Apr 13, 2018 6:15 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Sending DeliverSmResp asynchronously
Replies: 1
Views: 2821

Sending DeliverSmResp asynchronously

Hi, We would like to send the DeliverSmResp message asynchronously ie. after the DeliverSmEventHandler has returned (in case we cannot process the DeliverSm right now due to application state, ie external system not available). Is there a way to do this ? Or is the correct way of handling the event ...
by striemer
Fri Jun 02, 2017 6:18 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Handling of open submits after reconnect if disconnected
Replies: 1
Views: 3516

Handling of open submits after reconnect if disconnected

Hi All,

I am using SubmitAsync to submit messages. As there may be a disconnect happening while waiting for the submit completion, I wonder about the correct handling of messages which are waiting for the completion (ie. evSubmitComplete).

Thanks and best regards,
Stefan
by striemer
Wed Mar 15, 2017 5:58 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Multi-part UCS-2 message with surrogate pairs not working
Replies: 5
Views: 6229

Re: Multi-part UCS-2 message with surrogate pairs not workin

Awesome, thanks very much for the quick turnaround.
I have tested and confirm it works as expected.

Best regards,
Stefan
by striemer
Thu Mar 09, 2017 11:40 pm
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Multi-part UCS-2 message with surrogate pairs not working
Replies: 5
Views: 6229

Re: Multi-part UCS-2 message with surrogate pairs not workin

Hi, do you have a rough idea when a fix for this issue will be available ? We are getting close to releasing our SMS messaging functionality and would need a fix for this before the release date.

Thanks and best regards,
Stefan
by striemer
Tue Feb 28, 2017 11:40 pm
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Multi-part UCS-2 message with surrogate pairs not working
Replies: 5
Views: 6229

Re: Multi-part UCS-2 message with surrogate pairs not workin

Thanks very much for the quick response, much appreciated.

Best regards,
Stefan
by striemer
Mon Feb 27, 2017 8:02 am
Forum: Inetlab.SMPP v1.1 & v1.2
Topic: Multi-part UCS-2 message with surrogate pairs not working
Replies: 5
Views: 6229

Multi-part UCS-2 message with surrogate pairs not working

Hi All, While testing our SMPP functionality I have sent a text message which contains all emojis (codes 1F601-1F64F) using UCS-2 encoding. As emojis are outside the 16-Bit range they are encoded with surrogate pairs (ie. 2 16-Bit chars per emoji). First surrogate char is 0xD83D and the second one i...