Turkish message problem

lolorosso
Posts: 18
Joined: Sat Jan 02, 2021 5:31 pm

Re: Turkish message problem

Post by lolorosso » Mon Feb 01, 2021 9:19 pm

Yes, I get an error from the operator when sent this way.
alt
Site Admin
Posts: 904
Joined: Tue Apr 25, 2006 9:45 am

Re: Turkish message problem

Post by alt » Mon Feb 01, 2021 10:38 pm

I have release version 2.9.2. Please test it and let me know if the issue is fixed.

In the fixed version the 3rd part is 148 octets, because of the escaped character that takes 2 octets. Library always tries to keep the whole character in the message part. Therefore two octets character is shifted to the 4th part.
lolorosso
Posts: 18
Joined: Sat Jan 02, 2021 5:31 pm

Re: Turkish message problem

Post by lolorosso » Wed Feb 03, 2021 9:18 am

Hello, when I checked I did not find a problem with the version.
alt
Site Admin
Posts: 904
Joined: Tue Apr 25, 2006 9:45 am

Re: Turkish message problem

Post by alt » Wed Feb 03, 2021 7:13 pm

Thank you for information.
Let me know if you find any other issue.
lolorosso
Posts: 18
Joined: Sat Jan 02, 2021 5:31 pm

Re: Turkish message problem

Post by lolorosso » Fri Feb 05, 2021 11:32 am

Hello, in Turkish messages, the first piece consists of 155 characters.

Sample Text: Scyın veli, öğrencinizin MELTEM BİR öğretmeninden TÜRKÇE dersine verilen ödevi değerlendirilmiştir. Sisteme giriş yaparak kontrol edebilirsiniz. BXXX
alt
Site Admin
Posts: 904
Joined: Tue Apr 25, 2006 9:45 am

Re: Turkish message problem

Post by alt » Sat Feb 06, 2021 1:37 pm

Thank you for pointing this bug to me.
It is fixed in the version 2.9.4.
Post Reply